<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#" xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-gb" lang="en-gb">

<head>
    <script type="text/javascript">
var siteurl='/';
var tmplurl='/templates/ja_teline_iv/';
var isRTL = false;
</script>

  <base href="http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43" />
  <meta http-equiv="content-type" content="text/html; charset=utf-8" />
  <meta name="keywords" content="Saipan, Marianas, marianas, saipan, CNMI, cnmi, Saipan News, CNMI News, Tinian, tinian, Rota, rota, Marianas Variety, marianas variety, Variety, variety, Northern Mariana Islands, Younis Arts Studio, Younis" />
  <meta name="rights" content="Content cannot be used unless given permission by Marianas Variety or Younis Arts Studios. " />
  <meta name="author" content="By Zaldy Dandan - Editor" />
  <meta name="description" content="Marianas Variety - Saipan News &amp; Views - Micronesia's Leading Newspaper Since 1972. Saipan's 1st Interactive News Website." />
  <meta name="generator" content="Joomla! - Open Source Content Management" />
  <title>Marianas Variety - Northern Islands Mayor Jerome Aldan, 43</title>
  <link rel="stylesheet" href="/index.php?jat3action=gzip&amp;jat3type=css&amp;jat3file=t3-assets%2Fcss_fcaf0.css" type="text/css" />
  <link rel="stylesheet" href="/index.php?jat3action=gzip&amp;jat3type=css&amp;jat3file=t3-assets%2Fcss_f7aea.css" type="text/css" />
  <link rel="stylesheet" href="/index.php?jat3action=gzip&amp;jat3type=css&amp;jat3file=t3-assets%2Fcss_f7035.css" type="text/css" />
  <style type="text/css">
#ty2udate287 {}
  </style>
  <script src="/index.php?jat3action=gzip&amp;jat3type=js&amp;jat3file=t3-assets%2Fjs_f278a.js" type="text/javascript"></script>
  <script type="text/javascript">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</script>
  <meta property="fb:app_id" content="373788246027539" />
  <meta property="og:title" content="Northern Islands Mayor Jerome Aldan, 43" />
  <meta property="og:type" content="ogtypes" />
  <meta property="og:url" content="http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43" />
  <meta property="og:site_name" content="Marianas Variety" />

<!--[if ie]><link href="/plugins/system/jat3/jat3/base-themes/default/css/template-ie.css" type="text/css" rel="stylesheet" /><![endif]--> 
<!--[if ie]><link href="/templates/ja_teline_iv/css/template-ie.css" type="text/css" rel="stylesheet" /><![endif]--> 
<!--[if ie 7]><link href="/plugins/system/jat3/jat3/base-themes/default/css/template-ie7.css" type="text/css" rel="stylesheet" /><![endif]--> 
<!--[if ie 7]><link href="/templates/ja_teline_iv/css/template-ie7.css" type="text/css" rel="stylesheet" /><![endif]--> 




<link href="/templates/ja_teline_iv/images/favicon.ico" rel="shortcut icon" type="image/x-icon" />
    
    <style type="text/css">
/*dynamic css*/

    body.bd .main {width: 980px;}
    body.bd #ja-wrapper {min-width: 980px;}
</style></head>

<body id="bd" class="bd fs5 com_content">
<a name="Top" id="Top"></a>
<div id="ja-wrapper">


                <div id="ja-header"
            	class="wrap ">
                   <div class="main clearfix">
           <h1 class="logo">
		<a href="/index.php" title="Marianas Variety"><span>Marianas Variety</span></a>
	</h1>
		
	<div class="ja-header-r">
		

<div class="custom"  >
	<script>
  (function() {
    var cx = '008021793823546679917:qjf4zowrlcs';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div>

	</div>

	<div class="ja-header-clock">
                
        </div>            </div>
                        </div>
            <div id="ja-topmegamenu"
            	class="wrap ">
                   <div class="main clearfix">
           <div id="ja-topnav" class="clearfix">
	<div class="ja-megamenu clearfix" id="ja-topmega">
<ul class="megamenu level0"><li  class="mega first haschild nav-facebook"><a href="#"  class="mega first haschild nav-facebook" id="menu351" title="Facebook Like"><span class="menu-title">Facebook Like</span></a><div class="childcontent cols1 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 353px;">	<div class="ja-moduletable moduletable  clearfix" id="Mod318">
						<div class="ja-box-ct clearfix">
		<style>.fbInner{width:340px;}</style><div class="fbInner"><div class="textwidget"><script src="http://connect.facebook.net/en_GB/all.js#xfbml=1"></script><fb:fan profile_id="266082993493810" width ="340" height="520" connections ="25" stream ="0" logobar="1" css="http://www.mvariety.com/modules/mod_myfanbox_facebook/myfanbox.php?fanBoxColor=%23FFFFFF&textColor=%23000000&countFansSize=21&imgWidth=45&betweenImg=2&textShadow=0&fanLinkColor=%23000000&fanBoxinternalColor=%23FFFFFF&borderColor=%23000000&rand=24"></fb:fan><div dir="ltr" style="text-align: left;" trbidi="on"><div style="text-align: center;">
<span style="font-family: Verdana, sans-serif; font-size: xx-small;"></span></div>
</div></div></div> <noscript>JavaScript must be enabled in order for you to use the facebook Like Box. However, it seems JavaScript is either disabled or not supported by your browser. To use the facebook Like Box, enable JavaScript by changing your browser options, then <a href="http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43">try again.</a></noscript>		</div>
    </div>
	</div>
</div></div></li><li  class="mega nav-feeds"><a href="/?format=feed&amp;type=rss" target="_blank"  class="mega nav-feeds" id="menu365" title="RSS"><span class="menu-title">RSS</span></a></li><li  class="mega last nav-youtube"><a href="http://www.youtube.com/mvariety" target="_blank"  class="mega last nav-youtube" id="menu249" title="Youtube"><span class="menu-title">Youtube</span></a></li></ul>
</div>            <script type="text/javascript">
                var megamenu = new jaMegaMenuMoo ('ja-topmega', {
                    'bgopacity': 0,
                    'delayHide': 300,
                    'slide'    : 1,
                    'fading'   : 0,
                    'direction': 'down',
                    'action'   : 'mouseover',
                    'tips'     : false,
                    'duration' : 300,
                    'hidestyle': 'fastwhenshow'
                });
            </script>
            </div>
            </div>
                        </div>            <div id="ja-mainnav"
            	class="wrap ">
                   <div class="main clearfix">
           <div class="ja-megamenu clearfix" id="ja-megamenu">
<ul class="megamenu level0"><li  class="mega first haschild home"><a href="http://www.mvariety.com/"  class="mega first haschild home" id="menu137" title="Home"><span class="menu-title">Home</span></a><div class="childcontent cols1 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 200px;"><div class="megacol column1 first" style="width: 200px;"><ul class="megamenu level1"><li  class="mega first"><a href="/home-sp-445/about-us"  class="mega first" id="menu220" title="About Us"><span class="menu-title">About Us</span></a></li></ul></div></div>
</div></div></li><li  class="mega haschild active"><a href="/cnmi"  class="mega haschild active" id="menu138" title="CNMI"><span class="menu-title">CNMI</span></a><div class="childcontent cols3 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 900px;"><div class="megacol column1 first" style="width: 200px;"><ul class="megamenu level1"><li  class="mega first group"><div class="group"><div class="group-title"><a href="#"  class="mega first group" id="menu211" title="CNMI News"><span class="menu-title">CNMI News</span></a></div><div class="group-content"><ul class="megamenu level1"><li  class="mega first active"><a href="/cnmi/cnmi-news/local"  class="mega first active" id="menu107" title="Local"><span class="menu-title">Local</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/editorials"  class="mega" id="menu108" title="Editorials &amp; Columns"><span class="menu-title">Editorials &amp; Columns</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/letters-to-the-editor"  class="mega" id="menu112" title="Letters to the Editor"><span class="menu-title">Letters to the Editor</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/sports"  class="mega" id="menu109" title="Sports"><span class="menu-title">Sports</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/corrections"  class="mega" id="menu152" title="Corrections"><span class="menu-title">Corrections</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/obituaries"  class="mega" id="menu193" title="Obituaries"><span class="menu-title">Obituaries</span></a></li><li  class="mega last"><a href="/cnmi/cnmi-news/photo-gallery"  class="mega last" id="menu208" title="Photo Gallery"><span class="menu-title">Photo Gallery</span></a></li></ul></div></div></li></ul></div><div class="megacol column2" style="width: 350px;"><ul class="megamenu level1"><li  class="mega first group"><div class="group"><div class="group-title"><a href="#"  class="mega first group" id="menu212" title="Latest News"><span class="menu-title">Latest News</span></a></div><div class="group-content">	<div class="ja-moduletable moduletable_mega  clearfix" id="Mod210">
						<div class="ja-box-ct clearfix">
		<div class="ja-bulletin-wrap">
	<ul class="ja-bulletin_mega clearfix">
				<li class="clearfix">
												<div class="box-left">
			
									<a href="/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43" class="mostread-image">
						<img src="/images/resized/images/photos/Mugshots/JeromeAldan01_30_30.jpg" alt="Northern Islands Mayor Jerome Aldan, 43" title="Northern Islands Mayor Jerome Aldan, 43" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43" class="mostread">Northern Islands Mayor Jerome Aldan, 43</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/cnmi/cnmi-news/local/93125-rota-lawmakers-set-aside-politics-vow-to-work-together" class="mostread-image">
						<img src="/images/resized/images/photos/misc/rota08XL_30_30.jpg" alt="Rota lawmakers ‘set aside politics,’ vow to ‘work  together’" title="Rota lawmakers ‘set aside politics,’ vow to ‘work  together’" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/cnmi/cnmi-news/local/93125-rota-lawmakers-set-aside-politics-vow-to-work-together" class="mostread">Rota lawmakers ‘set aside politics,’ vow to ‘work  together’</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/cnmi/cnmi-news/editorials/93078-variations-god-bless-you-bishop-camacho" class="mostread-image">
						<img src="/images/resized/images/photos/Mugshots/ZaldyDandan01_30_30.jpg" alt="Variations: God bless you Bishop Camacho" title="Variations: God bless you Bishop Camacho" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/cnmi/cnmi-news/editorials/93078-variations-god-bless-you-bishop-camacho" class="mostread">Variations: God bless you Bishop Camacho</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/advertising/special-advertising-feature-2/93099-char-s-thrifty-store-opens-on-beach-road-today" class="mostread-image">
						<img src="/images/resized/images/photos/2017/02-Feb/17/chars_30_30.jpg" alt="Char’s Thrifty Store opens on Beach Road today" title="Char’s Thrifty Store opens on Beach Road today" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/advertising/special-advertising-feature-2/93099-char-s-thrifty-store-opens-on-beach-road-today" class="mostread">Char’s Thrifty Store opens on Beach Road today</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/regional-news/93080-melisa-david-somorang-and-the-beauty-of-sonsorol" class="mostread-image">
						<img src="/images/resized/images/photos/2017/02-Feb/17/Somorang_30_30.jpg" alt="Melisa David Somorang and the beauty of Sonsorol" title="Melisa David Somorang and the beauty of Sonsorol" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/regional-news/93080-melisa-david-somorang-and-the-beauty-of-sonsorol" class="mostread">Melisa David Somorang and the beauty of Sonsorol</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			</ul>
</div><script type="text/javascript">
  var Ja_direction = '';
  var cookie_path = '/';
  var cur_template_name = 'ja_teline_iv';
  window.addEvent('load', function(){

		   if(typeof(tmpl_name) =='undefined')
		   {
			  cookie_path = "ja_teline_iv_direction";
		   }
		   else
		   {
			  cookie_path = tmpl_name+"_direction";
		   }
		   Ja_direction = Cookie.read(cookie_path);
		   if(!Ja_direction)
		   {
				cookie_path = cookie_path.replace("_direction","_profile");
			   Ja_direction = Cookie.read(cookie_path);
		   }
		   var style_l_value = 'auto';
		   if(Ja_direction == 'rtl')
			{
			  			//	var ul_wrapper = $('Mod210').getElement("ul.ja-bulletin");
			//	ul_wrapper.getElements("li img").each();
			}
	});
</script>
<script type="text/javascript" language="javascript">
 function setStyleLinkWithRTLDirection()
 {
    var links = document.getElementsByTagName ('link');
		var script = document.createElement('link');
	script.setAttribute('type', 'text/css');
	script.setAttribute('rel', 'stylesheet');
	script.setAttribute('href', 'http://www.mvariety.com/modules/mod_jabulletin/assets/mod_jabuletin_rtl.css');
	document.getElementsByTagName("head")[0].appendChild(script);
 }
</script>		</div>
    </div>
	</div></div></li></ul></div><div class="megacol column3 last" style="width: 350px;"><ul class="megamenu level1"><li  class="mega first group"><div class="group"><div class="group-title"><a href="#"  class="mega first group" id="menu229" title="Most Read This Week"><span class="menu-title">Most Read This Week</span></a></div><div class="group-content">	<div class="ja-moduletable moduletable_mega  clearfix" id="Mod241">
						<div class="ja-box-ct clearfix">
		<div class="ja-bulletin-wrap">
	<ul class="ja-bulletin_mega clearfix">
				<li class="clearfix">
												<div class="box-left">
			
									<a href="/regional-news/93036-palau-commences-climate-change-and-disaster-risk-finance-assessment" class="mostread-image">
						<img src="/images/resized/images/photos/2017/02-Feb/16/palau_30_30.jpg" alt="Palau commences climate change and disaster risk finance assessment" title="Palau commences climate change and disaster risk finance assessment" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/regional-news/93036-palau-commences-climate-change-and-disaster-risk-finance-assessment" class="mostread">Palau commences climate change and disaster risk finance assessment</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/advertising/special-advertising-feature-2/92960-new-acupuncture-clinic-for-women-opens-on-saipan" class="mostread-image">
						<img src="/images/resized/images/photos/2017/02-Feb/14/acu1_30_30.jpg" alt="New acupuncture clinic for women opens on Saipan" title="New acupuncture clinic for women opens on Saipan" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/advertising/special-advertising-feature-2/92960-new-acupuncture-clinic-for-women-opens-on-saipan" class="mostread">New acupuncture clinic for women opens on Saipan</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/regional-news/93073-marshalls-women-go-to-court-for-domestic-abuse-protection" class="mostread-image">
						<img src="/images/resized/images/photos/2017/02-Feb/17/giff_30_30.jpg" alt="Marshalls’ women go to court for domestic abuse protection" title="Marshalls’ women go to court for domestic abuse protection" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/regional-news/93073-marshalls-women-go-to-court-for-domestic-abuse-protection" class="mostread">Marshalls’ women go to court for domestic abuse protection</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/regional-news/93067-federated-states-of-micronesia-trust-fund-94-12-million" class="mostread-image">
						<img src="/images/resized/images/photos/misc/fsmFlag06_30_30.jpg" alt="Federated States of Micronesia trust fund: $94.12 million" title="Federated States of Micronesia trust fund: $94.12 million" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/regional-news/93067-federated-states-of-micronesia-trust-fund-94-12-million" class="mostread">Federated States of Micronesia trust fund: $94.12 million</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/advertising/special-advertising-feature-2/92972-imperial-pacific-cleans-up-marpi-historical-sites" class="mostread-image">
						<img src="/images/resized/images/photos/2017/02-Feb/14/marpi_30_30.jpg" alt="Imperial Pacific cleans up Marpi historical sites" title="Imperial Pacific cleans up Marpi historical sites" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/advertising/special-advertising-feature-2/92972-imperial-pacific-cleans-up-marpi-historical-sites" class="mostread">Imperial Pacific cleans up Marpi historical sites</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			</ul>
</div><script type="text/javascript">
  var Ja_direction = '';
  var cookie_path = '/';
  var cur_template_name = 'ja_teline_iv';
  window.addEvent('load', function(){

		   if(typeof(tmpl_name) =='undefined')
		   {
			  cookie_path = "ja_teline_iv_direction";
		   }
		   else
		   {
			  cookie_path = tmpl_name+"_direction";
		   }
		   Ja_direction = Cookie.read(cookie_path);
		   if(!Ja_direction)
		   {
				cookie_path = cookie_path.replace("_direction","_profile");
			   Ja_direction = Cookie.read(cookie_path);
		   }
		   var style_l_value = 'auto';
		   if(Ja_direction == 'rtl')
			{
			  					setStyleLinkWithRTLDirection();
						//	var ul_wrapper = $('Mod241').getElement("ul.ja-bulletin");
			//	ul_wrapper.getElements("li img").each();
			}
	});
</script>
<script type="text/javascript" language="javascript">
 function setStyleLinkWithRTLDirection()
 {
    var links = document.getElementsByTagName ('link');
		var script = document.createElement('link');
	script.setAttribute('type', 'text/css');
	script.setAttribute('rel', 'stylesheet');
	script.setAttribute('href', 'http://www.mvariety.com/modules/mod_jabulletin/assets/mod_jabuletin_rtl.css');
	document.getElementsByTagName("head")[0].appendChild(script);
 }
</script>		</div>
    </div>
	</div></div></li></ul></div></div>
</div></div></li><li  class="mega"><a href="/regional-news"  class="mega" id="menu210" title="Regional News"><span class="menu-title">Regional News</span></a></li><li  class="mega"><a href="/community-bulletin-sp-595"  class="mega" id="menu123" title="Community Bulletins"><span class="menu-title">Community Bulletins</span></a></li><li  class="mega haschild"><a  class="mega haschild" id="menu158" title="Variety Features"><span class="menu-title">Variety Features</span></a><div class="childcontent cols1 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 200px;"><div class="megacol column1 first" style="width: 200px;"><ul class="megamenu level1"><li  class="mega first"><a href="/special-features/green-tips"  class="mega first" id="menu159" title="Green Tips"><span class="menu-title">Green Tips</span></a></li><li  class="mega"><a href="/special-features/health-matters"  class="mega" id="menu142" title="Health Matters"><span class="menu-title">Health Matters</span></a></li><li  class="mega"><a href="/special-features/my-marianas"  class="mega" id="menu241" title="My Marianas"><span class="menu-title">My Marianas</span></a></li><li  class="mega"><a href="/special-features/special-advertising-feature"  class="mega" id="menu202" title="Special Advertising Features"><span class="menu-title">Special Advertising Features</span></a></li><li  class="mega last"><a href="/special-features/special-events"  class="mega last" id="menu200" title="Special Events"><span class="menu-title">Special Events</span></a></li></ul></div></div>
</div></div></li><li  class="mega haschild"><a href="#"  class="mega haschild" id="menu195" title="Advertising"><span class="menu-title">Advertising</span></a><div class="childcontent cols1 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 200px;"><div class="megacol column1 first" style="width: 200px;"><ul class="megamenu level1"><li  class="mega first"><a href="/advertising/ad-rates"  class="mega first" id="menu132" title="Ad Rates"><span class="menu-title">Ad Rates</span></a></li><li  class="mega"><a href="/advertising/classifieds"  class="mega" id="menu439" title="Classifieds"><span class="menu-title">Classifieds</span></a></li><li  class="mega"><a href="/advertising/rfp-ifb"  class="mega" id="menu446" title="RFP &amp; IFB"><span class="menu-title">RFP &amp; IFB</span></a></li><li  class="mega"><a href="/advertising/special-advertising-feature-2"  class="mega" id="menu451" title="Special Advertising Features"><span class="menu-title">Special Advertising Features</span></a></li><li  class="mega last"><a href="/advertising/subscription" target="_blank"  class="mega last" id="menu116" title="Subscription"><span class="menu-title">Subscription</span></a></li></ul></div></div>
</div></div></li><li  class="mega"><a href="/contacts-sp-124"  class="mega" id="menu228" title="Contact Us"><span class="menu-title">Contact Us</span></a></li><li  class="mega last"><a href="http://www.postguam.com/"  class="mega last" id="menu453" title="Guahan News"><span class="menu-title">Guahan News</span></a></li></ul>
</div>            <script type="text/javascript">
                var megamenu = new jaMegaMenuMoo ('ja-megamenu', {
                    'bgopacity': 0,
                    'delayHide': 300,
                    'slide'    : 1,
                    'fading'   : 0,
                    'direction': 'down',
                    'action'   : 'mouseover',
                    'tips'     : false,
                    'duration' : 300,
                    'hidestyle': 'fastwhenshow'
                });
            </script>
            <!-- jdoc:include type="menu" level="0" / -->


<ul class="no-display">
    <li><a href="#ja-content" title="Skip to content">Skip to content</a></li>
</ul>            </div>
                        </div>
                        <div id="ja-topbar"
            	class="wrap ">
                   <div class="main clearfix">
           <!--
	<p class="ja-day clearfix">
	  <span class="day">Sun</span><span class="month">02</span><span class="date">19</span><span class="year">2017</span>	</p>-->
	 
	<p class="ja-updatetime"><span>Last update</span><em>Tue, 21 Feb 2017 12am</em></p>
	
			<div class="ja-healineswrap">
		
<div class="ja-headelines-buttons">
	<a class="ja-headelines-pre" onclick="return false;" href="/"><span>PREVIOUS</span></a>
    <a class="ja-headelines-next" onclick="return false;" href="/"><span>NEXT</span></a> 
</div>
	
	<em>Headlines:</em>
	<div   id="jalh-modid198" class="ja-headlines ">
		<div style="white-space:nowrap; " id="jahl-wapper-items-jalh-modid198">
		<!-- HEADLINE CONTENT -->
								<div class="ja-headlines-item jahl-horizontal" style="visibility:visible">
					<a  title="THE commonwealth is mourning the death of Northern Islands Mayor Jerome K. Aldan who passed away on Saturday. He was 43."  href="/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43"><span>Northern Islands Mayor Jerome Aldan, 43</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="ZARINAE Sapong and Josh Andrew were honored with 2017 Athletes of the Year awards, and their contributions and achievements in their respective sports were recognized during last Thursday’s Northern Marianas Sports Association’s Annual Awards Banquet at the Fiesta Resort &amp; Spa’s Hibiscus H..."  href="/cnmi/cnmi-news/sports/93101-sapong-andrew-are-athletes-of-the-year"><span>Sapong, Andrew are Athletes of the Year</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="NORTHERN Marianas Sports Association President and local attorney Michael White was very pleased with the turnout of the NMSA Annual Awards Banquet at Fiesta Resort on Thursday."  href="/cnmi/cnmi-news/sports/93102-nmsa-awards-reactions-from-the-show-floor"><span>NMSA Awards: Reactions from the show floor</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="TOP-SEEDED Bobby Cruz played his first in the men’s singles this season and pulled off a huge win yesterday over Tony Kim to clinch the finals of the 2017 White Coconut Classic Tennis Tournament at the Pacific Islands Club."  href="/cnmi/cnmi-news/sports/93103-cruz-villanueva-in-men-s-singles-finals"><span>Cruz, Villanueva in men’s singles finals</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(Press Release) — This is to invite interested individual to attend the Northern Marianas Athletics annual membership meeting on Feb. 23, 2017 at the Gilbert C. Ada Gymnasium conference room at 6 p.m."  href="/cnmi/cnmi-news/sports/93104-nma-to-elect-new-officers-on-feb-23"><span>NMA to elect new officers on Feb. 23</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THE Talaabwogh Falcons regained their two-run lead late in the game to beat the Enforcers in the opening of the Saipan Little League Baseball Tournament at the Francisco Tanko Palacios Baseball Field on Friday."  href="/cnmi/cnmi-news/sports/93105-falcons-survive-enforcers-5-3-in-little-league-opener"><span>Falcons survive Enforcers, 5-3 in Little League opener</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="TOP Development Inc. rallied to upset CTSI while Marianas Resort continued to bulldoze their way through their second blowout victory in last Friday’s games of the 2017 JEM Corporation LTD Customer Appreciation Basketball Tournament held at the Tan Siu Lin Sports Complex."  href="/cnmi/cnmi-news/sports/93106-tdi-slips-past-ctsi-marianas-resort-routs-builders"><span>TDI slips past CTSI, Marianas Resort routs Builders</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="WASHINGTON (Reuters) — A United States aircraft carrier strike group has begun patrols in the South China Sea amid growing tension with China over control of the disputed waterway and concerns it could become a flashpoint under the new U.S. administration."  href="/regional-news/93107-us-carrier-group-patrols-in-tense-south-china-sea"><span>US carrier group patrols in tense South China Sea</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THEY have been seen in the skies over the Pacific for more than 45 years.&nbsp; It is hard to imagine air travel across the ocean without them.&nbsp;"  href="/cnmi/cnmi-news/editorials/93109-bc-s-tales-of-the-pacific-the-last-747"><span>BC’s Tales of the Pacific: The Last 747</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="IMMIGRANTS are human beings who just want a better life."  href="/cnmi/cnmi-news/editorials/93110-opinion-no-limitation"><span>OPINION: No limitation</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="IT is called colloquially, Presidents’ Day, an occasion to remember all the presidents, not just George Washington (born February 22) but also, Abraham Lincoln (born February 12), and though Thomas Jefferson was born on April, he is sometimes included on the list.&nbsp;"  href="/cnmi/cnmi-news/editorials/93111-earthrise-the-trump-card"><span>earthrise: The Trump card</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="PRESIDENT Donald Trump is his own best advocate."  href="/cnmi/cnmi-news/editorials/93112-opinion-trump-schools-dishonest-media-in-freewheeling-press-conference"><span>OPINION: Trump schools dishonest media in freewheeling press conference</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(MTEC) — Marianas Tourism Education Council turned student attention to the indigenous Chamorro and Carolinian tradition of sailing during their presentation at Garapan Elementary on Wednesday, Feb. 15."  href="/cnmi/cnmi-news/local/93114-tourism-council-s-continuing-outreach-highlights-sailing-at-garapan-school"><span>Tourism council’s continuing outreach highlights sailing at Garapan school</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(Press Release) — First Hawaiian Bank Chairman and Chief Executive Officer Bob Harrison has announced the promotion of Parminder Sachdej to vice president."  href="/cnmi/cnmi-news/local/93115-first-hawaiian-bank-promotes-parm-sachdej"><span>First Hawaiian Bank promotes Parm Sachdej</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(Press Release) — The Saipan Hash House Harriers donated $866 to Karidat following their Red Dress/Lingerie Run on Feb. 11, 2017."  href="/cnmi/cnmi-news/local/93116-saipan-hash-house-harriers-make-donation-to-karidat"><span>Saipan Hash House Harriers make donation to Karidat</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="SOME students from the Saipan Seventh-day Adventist School conducted a cleanup on Beach Road, Friday morning."  href="/cnmi/cnmi-news/local/93117-sda-students-support-beautify-marianas-program"><span>SDA students support Beautify Marianas program</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="HAGÅTÑA (The Guam Daily Post) — Department of Corrections officers foiled another attempt to bring crystal methamphetamine into the prison, resulting in the arrest of a 44-year-old woman."  href="/cnmi/cnmi-news/local/93118-woman-caught-trying-to-smuggle-drugs-into-guam-prison"><span>Woman caught trying to smuggle drugs into Guam prison</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="HAGÅTÑA (The Guam Daily Post) — A Department of Parks and Recreation lifeguard who was fired for his failure to report criminal charges and for violating the government of Guam’s drug-free-workplace program is appealing what he considers his wrongful termination in an adverse-action appeal fil..."  href="/cnmi/cnmi-news/local/93119-guam-lifeguard-arrested-for-meth-possession-appeals-termination"><span>Guam lifeguard arrested for meth possession appeals termination</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="ATTORNEY Stephen Woodruff said he was “shocked and surprised” to learn that his client, Amalia Abo Guanlao, refused to sign a declaration to the court that stated that she was aware that he could not practice law before the commonwealth courts, the Department of Homeland Security, or the Executi..."  href="/cnmi/cnmi-news/local/93120-woodruff-withdraws-as-counsel-in-immigration-case"><span>Woodruff withdraws as counsel in immigration case</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(Press Release) — Attorney Juan Carlos Benitez, lobbyist and Trump campaign coordinator, will discuss the present status of the CW program and future possibilities at the Society for Human Resource Management-NMI chapter meeting at the Pacific Islands Club-Charley’s on Wednesday, Feb. 22, 2017, ..."  href="/community-bulletin-sp-595/93121-shrm-guest-speaker-to-discuss-cw-program"><span>SHRM guest speaker to discuss CW program</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="COMMONWEALTH Utilities Corp. acting executive director Gary Camacho on Friday said management is now reviewing the cost of the benefits, including hazardous pay, that will either be “incorporated” or “embedded” in the salaries of power and waste water personnel."  href="/cnmi/cnmi-news/local/93122-cuc-reviewing-hazardous-pay-proposal"><span>CUC reviewing hazardous-pay proposal</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="DA BAO Auto &amp; Tire Shop manager Yu Jian Chun donated two wheelchairs to the CNMI medical referral services office on Guam."  href="/cnmi/cnmi-news/local/93123-da-bao-auto-donates-wheelchairs-to-medical-referral-office"><span>Da Bao Auto donates wheelchairs to medical referral office</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THE local Department of Labor told the manager/owner of Xing Wang Development Corp., doing business as the Family Store, that ignorance of the law is not a valid defense and does not excuse her from her responsibilities."  href="/cnmi/cnmi-news/local/93124-cnmi-labor-says-ignorance-of-the-law-is-not-a-valid-defense"><span>CNMI Labor says ignorance of the law is not a valid defense</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THE four members of the Rota Legislative Delegation finally convened on Friday and pledged to “put aside politics and focus on working together to resolve the issues affecting Rota right now.”"  href="/cnmi/cnmi-news/local/93125-rota-lawmakers-set-aside-politics-vow-to-work-together"><span>Rota lawmakers ‘set aside politics,’ vow to ‘work  together’</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="DEFENDING champion the Mount Carmel School Knights prevailed in this year’s CNMI mock trial competition, besting Grace Christian Academy in the final round on Friday at the judicial complex in Susupe."  href="/cnmi/cnmi-news/local/93126-mount-carmel-repeats-as-mock-trial-champion"><span>Mount Carmel repeats as mock trial champion</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="WASHINGTON (Reuters) — The Trump administration plans to direct immigration agents to greatly expand the categories of immigrants they target for deportation, according to drafts of two memos seen by Reuters and first reported by McClatchy news organization on Saturday."  href="/cnmi/cnmi-news/local/93128-trump-administration-to-expand-groups-of-immigrants-to-be-deported-documents"><span>Trump administration to expand groups  of immigrants to be deported: documents</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(Press Release) — Through its corporate responsibility platform Hyatt Thrive, Hyatt Regency Saipan will host the 21st Annual Charity Golf Classic on Saturday, April, 22, 2017. The annual event is a vehicle to raise funds on behalf of the Make-A-Wish Foundation and another local non-profit organiza..."  href="/community-bulletin-sp-595/93129-hyatt-golf-classic-extends-beneficiary-deadline"><span>Hyatt golf classic extends beneficiary deadline</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THE next Northern Mariana Islands Swimming Federation meet is this Saturday’s Saipan Swim Club Pentathlon at the Kan Pacific Marpi Pool."  href="/cnmi/cnmi-news/sports/93058-ssc-pentathlon-this-weekend"><span>SSC Pentathlon this weekend</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(Press Release) — Hyatt Regency Saipan welcomes a generous cash donation from long-standing even partner Tan Siu Lin Foundation for this year’s 21st Annual Charity Golf Classic."  href="/cnmi/cnmi-news/sports/93059-tan-siu-lin-foundation-marianas-printing-support-21st-annual-charity-golf-classic"><span>Tan Siu Lin Foundation, Marianas Printing support 21st Annual Charity Golf Classic</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(MVA) — Residents getting their first taste of Ironman 70.3 Saipan when the international race comes to the Marianas on March 11, 2017 will enjoy a sweet deal on registration, as well."  href="/cnmi/cnmi-news/sports/93060-special-rate-for-nmi-residents-for-ironman-70-3-saipan"><span>Special rate for NMI residents for Ironman 70.3 Saipan</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(Press Release) — This year’s annual Saipan Chamber of Commerce 2017 Golf Tournament is looking to bring back some fun to the golf course."  href="/cnmi/cnmi-news/sports/93061-saipan-chamber-of-commerce-2017-golf-tournament-on-march-4"><span>Saipan Chamber Of Commerce 2017 Golf Tournament on March 4</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="DEFENDING champions CK Bears and the runner-ups, BSI Aces will open the 2017 Saipan Baseball League season with a rematch on Feb. 20."  href="/cnmi/cnmi-news/sports/93062-bears-aces-rematch-in-sbl-opening"><span>Bears-Aces rematch in SBL opening </span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="JOETEN Enterprises and Top Development continued to climb in the 2017 JEM Corporation LTD Customer Appreciation Basketball Tournament after defeating their respective opponents last Wednesday at the Tan Siu Lin Sports Complex."  href="/cnmi/cnmi-news/sports/93063-joeten-tdi-keep-climbing-in-jem-corp-ltd-caging"><span>Joeten, TDI keep climbing in JEM Corp. LTD caging</span>
					</a> 
				</div>
						<!-- //HEADLINE CONTENT -->
		</div>	
	</div>
	
</div>
<script type="text/javascript">
// options setting
var options = { box:$('jalh-modid198'),
				items: $$('#jalh-modid198 .ja-headlines-item'),
				mode: 'horizontal',
				wrapper:$('jahl-wapper-items-jalh-modid198'),
				buttons:{next: $$('.ja-headelines-next'), previous: $$('.ja-headelines-pre')},
				interval:3000,
				fxOptions : { duration: 500,
							  transition: Fx.Transitions.linear ,
							  wait: false }	};

var jahl = new JANewSticker( options );
</script>

		
	
	         <div id="ja-headtools" class="ja-headtool">
  <ul>             
        <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#">
<head>
</head>
<body>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
</body>
</html><span id="ty2udate287"><div style="margin:0px auto;width:auto;text-align:right;">Sunday, February 19, 2017-7:08:43A.M.</div></span><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#">
<head>
</head>
<body>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
</body>
</html>
    </ul>
</div>            </div>
                        </div>
            
    <!-- MAIN CONTAINER -->
    <div id="ja-container" class="wrap ja-r1">
               <div class="main">
                           <div class="main-inner1 clearfix">
                        <div id="ja-mainbody" style="width:82.99%">
            <!-- CONTENT -->
            <div id="ja-main" style="width:99.99%">
            <div class="inner clearfix">

                
<div id="system-message-container">
</div>
                
                <div id="ja-contentwrap" class="clearfix ">
                    <div id="ja-content" class="column" style="width:99.99%">
                        <div id="ja-current-content" class="column" style="width:99.99%">
                            
                                                        <div id="ja-content-main" class="ja-content-main clearfix">
                                <div class="item-page">
	<h2 class="contentheading">
			<a href="/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43">
		Northern Islands Mayor Jerome Aldan, 43</a>
		</h2>

	
<div class="article-tools clearfix">
	<ul class="actions">
						<li class="print-icon">
			<a href="/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43?tmpl=component&amp;print=1&amp;layout=default&amp;page=" title="Print" onclick="window.open(this.href,'win2','status=no,toolbar=no,scrollbars=yes,titlebar=no,menubar=no,resizable=yes,width=640,height=480,directories=no,location=no'); return false;" rel="nofollow"><img src="/media/system/images/printButton.png" alt="Print"  /></a>			</li>
		
					<li class="email-icon">
			<a href="/component/mailto/?tmpl=component&amp;template=ja_teline_iv&amp;link=c5c3ced2efe7edae91ce9d8b5a654a1221413f4a" title="Email" onclick="window.open(this.href,'win2','width=400,height=350,menubar=yes,resizable=yes'); return false;"><img src="/media/system/images/emailButton.png" alt="Email"  /></a>			</li>
				
				
		
	</ul>



	<dl class="article-info">
	<dt class="article-info-term"></dt>
	<dd class="create ja-blog-date">
			<div class="inner clearfix">
								<span class="date">20</span>
				<span class="month-year">
					<strong>Feb</strong>
					<strong>2017</strong>
				</span>
							</div>
	</dd>
	<dd class="createdby"> 
				By Junhan B. Todiño - junhan@mvariety.com - Variety News Staff		</dd>
	
	</dl>
</div>
	<div class="bt-social-share bt-social-share-above"><div class="bt-social-share-button bt-facebook-share-button"><img class="fb-share" src="http://www.mvariety.com//plugins/content/bt_socialshare/assets/share.png" onClick="window.open('http://www.facebook.com/sharer.php?u='+encodeURIComponent('http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43')+'&t='+encodeURIComponent('Northern Islands Mayor Jerome Aldan, 43'),'sharer','toolbar=0,status=0,left='+((screen.width/2)-300)+',top='+((screen.height/2)-200)+',width=600,height=360');" href="javascript: void(0)" /></div><div class="bt-social-share-button bt-facebook-like-button"><fb:like send="false" colorscheme="light" font="arial" href="http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43" layout="button_count" width="70" show_faces="true" action="like"></fb:like></div><div class="bt-social-share-button bt-twitter-button" style="width:80px"><a href="http://twitter.com/share" class="twitter-share-button" 
						  data-via="Marianas Variety" 
						  data-url="http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43" 
						  data-size="medium"
						  data-lang="en"
						  data-count="horizontal" >Twitter</a></div><div class="bt-social-share-button bt-googleplus-button"><g:plus action="share" href="http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43" annotation="bubble" height="20" ></g:plus></div></div>

<!-- JoomlaWorks "DISQUS Comments for Joomla!" (v3.2) starts here -->

<span id="startOfPage"></span>


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#">
<head>
</head>
<body>
<p style="text-align: justify;">THE commonwealth is mourning the death of Northern Islands Mayor Jerome K. Aldan who passed away on Saturday. He was 43.</p>
 
<p style="text-align: justify;">His consultant, former Rep. William Torres, said Aldan was having a late dinner at J’s Restaurant on Beach Road when the mayor suddenly collapsed at 1 a.m. He was immediately brought to the hospital but was pronounced dead at 3 a.m.<img src="/images/photos/Mugshots/JeromeAldan01.jpg" alt="" style="float: right;" width="1" height="1" /></p>
<p style="text-align: justify;">The mayor’s mother, Clotilde K. Aldan, said the doctor told her in the emergency room that her son had died of a heart attack.</p>
<p style="text-align: justify;">Mrs. Aldan said Gov. Ralph Torres rushed to the hospital on Saturday morning upon hearing the news.</p>
<p style="text-align: justify;">She said they were all shocked when they heard that her son was brought to the hospital. “We thought he had figured in an accident,” she added.</p>
<p style="text-align: justify;">It was only a few days ago that her son visited her house at Paganville in Garapan where he also resided.</p>
<p style="text-align: justify;">She said every time her son would visit her, he would ask her to braid his long hair.</p>
<p style="text-align: justify;">“The last time he visited he had lots of stories to tell,” Mrs. Aldan said, adding that she, for her part, would always ask the mayor about his health.</p>
<p style="text-align: justify;">“I didn’t want him to be stressed,” she said.</p>
<p style="text-align: justify;">She said he son, who was always “cheerful” liked to joke, and would always assure her that he was fine.<br /><br /><img src="/images/photos/2017/02-Feb/17/jerome.jpg" alt="Clotilde K. Aldan, right, the mother of the late Northern Islands Mayor Jerome Aldan, is hosting a nightly rosary for her son at her house at Paganville in Garapan.  Photo by Junhan B. Todño" title="Clotilde K. Aldan, right, the mother of the late Northern Islands Mayor Jerome Aldan, is hosting a nightly rosary for her son at her house at Paganville in Garapan.  Photo by Junhan B. Todño" class="caption" style="display: block; margin-left: auto; margin-right: auto;" /></p>
<p style="text-align: justify;">Jerome Aldan is survived by his children Lany, Zachary, Zasha, Zavannah and Zodeanna.</p>
<p style="text-align: justify;">Mayor Aldan was the eldest son of the late Northern Islands Mayor Tobias Aldan Sr., 68, who passed away in March 2015.</p>
<p style="text-align: justify;">Jerome Aldan’s brothers and sisters are Jennifer, Joylina (deceased), Tobias Jr., Rockson and Jocelyn.</p>
<p style="text-align: justify;">Former Rep. William Torres, in a separate interview, said the Saipan and Northern Islands Municipal Council, acting Northern Islands Mayor Luis John Castro and Saipan Mayor David Apatang are now meeting to discuss the state funeral of the late Mayor Jerome Aldan.</p>
<p style="text-align: justify;">Council vice chair Diego Kaipat, Jerome Aldan’s uncle, is the council’s liaison to the Aldan family.</p>
<p style="text-align: justify;">Mrs. Clotilde Aldan said the nightly rosary started on Sunday at 7:30 p.m. at her house in Paganville.</p>
<p style="text-align: justify;">She said they will decide on the date of the funeral once Jerome Aldan’s son, Zachary, arrives this week.</p>
<p style="text-align: justify;">Zachary “Z-Boy” Camacho Aldan recently completed his basic combat training and advanced training at Ft. Jackson in South Carolina.</p>
<p style="text-align: justify;">Governor Torres expressed his condolences to the family of Mayor Jerome Aldan.</p>
<p style="text-align: justify;">“First lady Diann, the lt. governor and second lady Villia and our families ask all of you to please keep his spouse and children in your thoughts and prayers.”</p>
<p style="text-align: justify;">In his message, acting Northern Islands Mayor Castro said: “Mayor Aldan was a guy who had great love for the people he served. Our council vice chairman lost a beloved nephew, and we all lost a great friend. My wife Elaine and I offer our condolences to his family and friends, and most importantly his constituents who are mourning his passing. I ask all of you for prayers for the repose of his soul during this difficult time.”</p>
</body>
</html>
<!-- DISQUS comments block -->
<div class="jwDisqusForm">
<hr />
<img src="/plugins/content/jw_disqus/jw_disqus/tmpl/images/addacomment.png">
	
			<div id="disqus_thread"></div>
			<script type="text/javascript">
				//<![CDATA[
				var disqus_shortname = 'mvariety';
				var disqus_url = 'http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43';
				var disqus_identifier = 'd8d2d98882_id93100';
				var disqus_developer = '0';
				var disqus_config = function(){
					this.language = '';
				};
				(function() {
					var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
					dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
					(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
				})();
				//]]>
			</script>
			<noscript>
				<a href="http://mvariety.disqus.com/?url=ref">View the discussion thread.</a>
			</noscript>
				<div id="jwDisqusFormFooter">
		<a target="_blank" href="http://disqus.com" class="dsq-brlink">
			blog comments powered by <span class="logo-disqus">DISQUS</span>
		</a>
		<a id="jwDisqusBackToTop" href="http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43#Top">
			back to top		</a>
		<div class="clr"></div>
	</div>
</div>

<div class="clr"></div>


<!-- JoomlaWorks "DISQUS Comments for Joomla!" (v3.2) ends here -->
<div class="fb-recommendations-bar" data-href="http://www.mvariety.com/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43" data-read-time="30" data-action="like" data-trigger="onvisible" data-side="right" data-num_recommendations="2"></div><div id="fb-root"></div>
				<script>(function(d, s, id) {
				  var js, fjs = d.getElementsByTagName(s)[0];
				  if (d.getElementById(id)) {return;}
				  js = d.createElement(s); js.id = id;
				  js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1";
				  fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));</script><script src="//platform.twitter.com/widgets.js" type="text/javascript"></script><script type="text/javascript" src="https://apis.google.com/js/plusone.js">{lang: 'en-GB'}</script>	
	</div>                            </div>
                            
                                                    </div>

                                            </div>

                    
                </div>

                            </div>
            </div>
            <!-- //CONTENT -->
            
        </div>
                <!-- RIGHT COLUMN-->
        <div id="ja-right" class="column sidebar" style="width:17%">

            
                        <div class="ja-colswrap clearfix ja-r1">
                                <div id="ja-right1" class="ja-col  column" style="width:100%">
                    	<div class="ja-moduletable moduletable  clearfix" id="Mod253">
						<h3><span>More News</span></h3>
				<div class="ja-box-ct clearfix">
		<ul class="latestnews">
	<li>
		<a href="/cnmi/cnmi-news/local/93100-northern-islands-mayor-jerome-aldan-43">
			Northern Islands Mayor Jerome Aldan, 43</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93114-tourism-council-s-continuing-outreach-highlights-sailing-at-garapan-school">
			Tourism council’s continuing outreach highlights sailing at Garapan school</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93115-first-hawaiian-bank-promotes-parm-sachdej">
			First Hawaiian Bank promotes Parm Sachdej</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93116-saipan-hash-house-harriers-make-donation-to-karidat">
			Saipan Hash House Harriers make donation to Karidat</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93117-sda-students-support-beautify-marianas-program">
			SDA students support Beautify Marianas program</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93118-woman-caught-trying-to-smuggle-drugs-into-guam-prison">
			Woman caught trying to smuggle drugs into Guam prison</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93119-guam-lifeguard-arrested-for-meth-possession-appeals-termination">
			Guam lifeguard arrested for meth possession appeals termination</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93120-woodruff-withdraws-as-counsel-in-immigration-case">
			Woodruff withdraws as counsel in immigration case</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93122-cuc-reviewing-hazardous-pay-proposal">
			CUC reviewing hazardous-pay proposal</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93123-da-bao-auto-donates-wheelchairs-to-medical-referral-office">
			Da Bao Auto donates wheelchairs to medical referral office</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93124-cnmi-labor-says-ignorance-of-the-law-is-not-a-valid-defense">
			CNMI Labor says ignorance of the law is not a valid defense</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93125-rota-lawmakers-set-aside-politics-vow-to-work-together">
			Rota lawmakers ‘set aside politics,’ vow to ‘work  together’</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93126-mount-carmel-repeats-as-mock-trial-champion">
			Mount Carmel repeats as mock trial champion</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/93128-trump-administration-to-expand-groups-of-immigrants-to-be-deported-documents">
			Trump administration to expand groups  of immigrants to be deported: documents</a>
	</li>
</ul>
		</div>
    </div>
	                </div>
                
                            </div>
                                </div>
        <!-- //RIGHT COLUMN-->
                            </div>
                            </div>
                </div>
        <!-- //MAIN CONTAINER -->

                <div id="ja-footer"
            	class="wrap ">
                   <div class="main">
                           <div class="main-inner1 clearfix">
                <div class="ja-footnav">
		
<ul class="menu-nav">
<li class="item-231"><a href="http://www.mvariety.com" >Home</a></li><li class="item-232"><a href="/cnmi-sp-769" >CNMI</a></li><li class="item-236"><a href="#" >Regional News</a></li><li class="item-230"><a href="/community-bulletin-sp-950" >Community Bulletin</a></li><li class="item-233"><a href="/special-features-sp-395" >Variety Features</a></li><li class="item-235"><a href="#" >Advertising</a></li><li class="item-204"><a href="/contact-us" >Contact Us</a></li><li class="item-203"><a href="/user-content-posting-rules" >User Content Posting Rules</a></li></ul>

				<ul class="ja-links">
						<li class="top"><a href="#Top" title="Back to Top">Top</a></li>
		</ul>
		
		<ul class="no-display">
			<li><a href="#ja-content" title="Skip to content">Skip to content</a></li>
		</ul>
	</div>
		
	<div class="ja-copyright">
		

<div class="custom"  >
	<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#">
<head>
</head>
<body>
<p><small>Copyright © 2013 Marianas Variety. All Rights Reserved. Published by Younis Art Studio Inc.</small></p>
</body>
</html></div>

	</div>                </div>
                            </div>
                        </div>
            
</div>

    

</body>

</html>