<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#" xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-gb" lang="en-gb">

<head>
    <script type="text/javascript">
var siteurl='/';
var tmplurl='/templates/ja_teline_iv/';
var isRTL = false;
</script>

  <base href="http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000" />
  <meta http-equiv="content-type" content="text/html; charset=utf-8" />
  <meta name="keywords" content="Saipan, Marianas, marianas, saipan, CNMI, cnmi, Saipan News, CNMI News, Tinian, tinian, Rota, rota, Marianas Variety, marianas variety, Variety, variety, Northern Mariana Islands, Younis Arts Studio, Younis" />
  <meta name="rights" content="Content cannot be used unless given permission by Marianas Variety or Younis Arts Studios. " />
  <meta name="author" content="Marianas Variety" />
  <meta name="description" content="Marianas Variety - Saipan News &amp; Views - Micronesia's Leading Newspaper Since 1972. Saipan's 1st Interactive News Website." />
  <meta name="generator" content="Joomla! - Open Source Content Management" />
  <title>Marianas Variety - Biyu Hu arrested for ice trafficking; bail set at $500,000</title>
  <link rel="stylesheet" href="/index.php?jat3action=gzip&amp;jat3type=css&amp;jat3file=t3-assets%2Fcss_fcaf0.css" type="text/css" />
  <link rel="stylesheet" href="/index.php?jat3action=gzip&amp;jat3type=css&amp;jat3file=t3-assets%2Fcss_f7aea.css" type="text/css" />
  <link rel="stylesheet" href="/index.php?jat3action=gzip&amp;jat3type=css&amp;jat3file=t3-assets%2Fcss_f7035.css" type="text/css" />
  <style type="text/css">
#ty2udate287 {}
  </style>
  <script src="/index.php?jat3action=gzip&amp;jat3type=js&amp;jat3file=t3-assets%2Fjs_f278a.js" type="text/javascript"></script>
  <script type="text/javascript">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</script>
  <meta property="fb:app_id" content="373788246027539" />
  <meta property="og:title" content="Biyu Hu arrested for ice trafficking; bail set at $500,000" />
  <meta property="og:type" content="ogtypes" />
  <meta property="og:url" content="http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000" />
  <meta property="og:site_name" content="Marianas Variety" />

<!--[if ie]><link href="/plugins/system/jat3/jat3/base-themes/default/css/template-ie.css" type="text/css" rel="stylesheet" /><![endif]--> 
<!--[if ie]><link href="/templates/ja_teline_iv/css/template-ie.css" type="text/css" rel="stylesheet" /><![endif]--> 
<!--[if ie 7]><link href="/plugins/system/jat3/jat3/base-themes/default/css/template-ie7.css" type="text/css" rel="stylesheet" /><![endif]--> 
<!--[if ie 7]><link href="/templates/ja_teline_iv/css/template-ie7.css" type="text/css" rel="stylesheet" /><![endif]--> 




<link href="/templates/ja_teline_iv/images/favicon.ico" rel="shortcut icon" type="image/x-icon" />
    
    <style type="text/css">
/*dynamic css*/

    body.bd .main {width: 980px;}
    body.bd #ja-wrapper {min-width: 980px;}
</style></head>

<body id="bd" class="bd fs5 com_content">
<a name="Top" id="Top"></a>
<div id="ja-wrapper">


                <div id="ja-header"
            	class="wrap ">
                   <div class="main clearfix">
           <h1 class="logo">
		<a href="/index.php" title="Marianas Variety"><span>Marianas Variety</span></a>
	</h1>
		
	<div class="ja-header-r">
		

<div class="custom"  >
	<script>
  (function() {
    var cx = '008021793823546679917:qjf4zowrlcs';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div>

	</div>

	<div class="ja-header-clock">
                
        </div>            </div>
                        </div>
            <div id="ja-topmegamenu"
            	class="wrap ">
                   <div class="main clearfix">
           <div id="ja-topnav" class="clearfix">
	<div class="ja-megamenu clearfix" id="ja-topmega">
<ul class="megamenu level0"><li  class="mega first haschild nav-facebook"><a href="#"  class="mega first haschild nav-facebook" id="menu351" title="Facebook Like"><span class="menu-title">Facebook Like</span></a><div class="childcontent cols1 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 353px;">	<div class="ja-moduletable moduletable  clearfix" id="Mod318">
						<div class="ja-box-ct clearfix">
		<style>.fbInner{width:340px;}</style><div class="fbInner"><div class="textwidget"><script src="http://connect.facebook.net/en_GB/all.js#xfbml=1"></script><fb:fan profile_id="266082993493810" width ="340" height="520" connections ="25" stream ="0" logobar="1" css="http://www.mvariety.com/modules/mod_myfanbox_facebook/myfanbox.php?fanBoxColor=%23FFFFFF&textColor=%23000000&countFansSize=21&imgWidth=45&betweenImg=2&textShadow=0&fanLinkColor=%23000000&fanBoxinternalColor=%23FFFFFF&borderColor=%23000000&rand=217"></fb:fan><div dir="ltr" style="text-align: left;" trbidi="on"><div style="text-align: center;">
<span style="font-family: Verdana, sans-serif; font-size: xx-small;"></span></div>
</div></div></div> <noscript>JavaScript must be enabled in order for you to use the facebook Like Box. However, it seems JavaScript is either disabled or not supported by your browser. To use the facebook Like Box, enable JavaScript by changing your browser options, then <a href="http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000">try again.</a></noscript>		</div>
    </div>
	</div>
</div></div></li><li  class="mega nav-feeds"><a href="/?format=feed&amp;type=rss" target="_blank"  class="mega nav-feeds" id="menu365" title="RSS"><span class="menu-title">RSS</span></a></li><li  class="mega last nav-youtube"><a href="http://www.youtube.com/mvariety" target="_blank"  class="mega last nav-youtube" id="menu249" title="Youtube"><span class="menu-title">Youtube</span></a></li></ul>
</div>            <script type="text/javascript">
                var megamenu = new jaMegaMenuMoo ('ja-topmega', {
                    'bgopacity': 0,
                    'delayHide': 300,
                    'slide'    : 1,
                    'fading'   : 0,
                    'direction': 'down',
                    'action'   : 'mouseover',
                    'tips'     : false,
                    'duration' : 300,
                    'hidestyle': 'fastwhenshow'
                });
            </script>
            </div>
            </div>
                        </div>            <div id="ja-mainnav"
            	class="wrap ">
                   <div class="main clearfix">
           <div class="ja-megamenu clearfix" id="ja-megamenu">
<ul class="megamenu level0"><li  class="mega first haschild home"><a href="http://www.mvariety.com/"  class="mega first haschild home" id="menu137" title="Home"><span class="menu-title">Home</span></a><div class="childcontent cols1 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 200px;"><div class="megacol column1 first" style="width: 200px;"><ul class="megamenu level1"><li  class="mega first"><a href="/home-sp-445/about-us"  class="mega first" id="menu220" title="About Us"><span class="menu-title">About Us</span></a></li></ul></div></div>
</div></div></li><li  class="mega haschild active"><a href="/cnmi"  class="mega haschild active" id="menu138" title="CNMI"><span class="menu-title">CNMI</span></a><div class="childcontent cols3 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 900px;"><div class="megacol column1 first" style="width: 200px;"><ul class="megamenu level1"><li  class="mega first group"><div class="group"><div class="group-title"><a href="#"  class="mega first group" id="menu211" title="CNMI News"><span class="menu-title">CNMI News</span></a></div><div class="group-content"><ul class="megamenu level1"><li  class="mega first active"><a href="/cnmi/cnmi-news/local"  class="mega first active" id="menu107" title="Local"><span class="menu-title">Local</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/editorials"  class="mega" id="menu108" title="Editorials &amp; Columns"><span class="menu-title">Editorials &amp; Columns</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/letters-to-the-editor"  class="mega" id="menu112" title="Letters to the Editor"><span class="menu-title">Letters to the Editor</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/sports"  class="mega" id="menu109" title="Sports"><span class="menu-title">Sports</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/corrections"  class="mega" id="menu152" title="Corrections"><span class="menu-title">Corrections</span></a></li><li  class="mega"><a href="/cnmi/cnmi-news/obituaries"  class="mega" id="menu193" title="Obituaries"><span class="menu-title">Obituaries</span></a></li><li  class="mega last"><a href="/cnmi/cnmi-news/photo-gallery"  class="mega last" id="menu208" title="Photo Gallery"><span class="menu-title">Photo Gallery</span></a></li></ul></div></div></li></ul></div><div class="megacol column2" style="width: 350px;"><ul class="megamenu level1"><li  class="mega first group"><div class="group"><div class="group-title"><a href="#"  class="mega first group" id="menu212" title="Latest News"><span class="menu-title">Latest News</span></a></div><div class="group-content">	<div class="ja-moduletable moduletable_mega  clearfix" id="Mod210">
						<div class="ja-box-ct clearfix">
		<div class="ja-bulletin-wrap">
	<ul class="ja-bulletin_mega clearfix">
				<li class="clearfix">
												<div class="box-left">
			
									<a href="/community-bulletin-sp-595/95363-bbq-pork-ribs-cook-off-at-taste-on-may-20" class="mostread-image">
						<img src="/images/resized/images/photos/2017/05-May/18/cookoff_30_30.jpg" alt="BBQ Pork Ribs Cook Off at ‘Taste’ on May 20" title="BBQ Pork Ribs Cook Off at ‘Taste’ on May 20" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/community-bulletin-sp-595/95363-bbq-pork-ribs-cook-off-at-taste-on-may-20" class="mostread">BBQ Pork Ribs Cook Off at ‘Taste’ on May 20</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/community-bulletin-sp-595/95243-nmi-author-goes-on-us-book-tour" class="mostread-image">
						<img src="/images/resized/images/photos/2017/05-May/15/book_30_30.jpg" alt="NMI author goes on US book tour" title="NMI author goes on US book tour" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/community-bulletin-sp-595/95243-nmi-author-goes-on-us-book-tour" class="mostread">NMI author goes on US book tour</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/special-features/my-marianas/95166-taste-returns-on-may-13-with-kadun-pika-cook-off" class="mostread-image">
						<img src="/images/resized/images/photos/2017/05-May/11/mva2_30_30.jpg" alt="‘Taste’ returns on May 13 with ‘Kadun Pika’ Cook Off" title="‘Taste’ returns on May 13 with ‘Kadun Pika’ Cook Off" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/special-features/my-marianas/95166-taste-returns-on-may-13-with-kadun-pika-cook-off" class="mostread">‘Taste’ returns on May 13 with ‘Kadun Pika’ Cook Off</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/special-features/my-marianas/94942-student-activities-kick-off-tourism-month" class="mostread-image">
						<img src="/images/resized/images/photos/2017/05-May/03/mva_30_30.jpg" alt="Student activities kick off Tourism Month" title="Student activities kick off Tourism Month" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/special-features/my-marianas/94942-student-activities-kick-off-tourism-month" class="mostread">Student activities kick off Tourism Month</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/home-sp-445/about-us" class="mostread-image">
						<img src="/images/resized/images/photos/misc/mv03s_30_30.jpg" alt="Younis Art Studio Inc. - Marianas Variety News &amp; Views" title="Younis Art Studio Inc. - Marianas Variety News &amp; Views" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/home-sp-445/about-us" class="mostread">Younis Art Studio Inc. - Marianas Variety News &amp; Views</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			</ul>
</div><script type="text/javascript">
  var Ja_direction = '';
  var cookie_path = '/';
  var cur_template_name = 'ja_teline_iv';
  window.addEvent('load', function(){

		   if(typeof(tmpl_name) =='undefined')
		   {
			  cookie_path = "ja_teline_iv_direction";
		   }
		   else
		   {
			  cookie_path = tmpl_name+"_direction";
		   }
		   Ja_direction = Cookie.read(cookie_path);
		   if(!Ja_direction)
		   {
				cookie_path = cookie_path.replace("_direction","_profile");
			   Ja_direction = Cookie.read(cookie_path);
		   }
		   var style_l_value = 'auto';
		   if(Ja_direction == 'rtl')
			{
			  			//	var ul_wrapper = $('Mod210').getElement("ul.ja-bulletin");
			//	ul_wrapper.getElements("li img").each();
			}
	});
</script>
<script type="text/javascript" language="javascript">
 function setStyleLinkWithRTLDirection()
 {
    var links = document.getElementsByTagName ('link');
		var script = document.createElement('link');
	script.setAttribute('type', 'text/css');
	script.setAttribute('rel', 'stylesheet');
	script.setAttribute('href', 'http://www.mvariety.com/modules/mod_jabulletin/assets/mod_jabuletin_rtl.css');
	document.getElementsByTagName("head")[0].appendChild(script);
 }
</script>		</div>
    </div>
	</div></div></li></ul></div><div class="megacol column3 last" style="width: 350px;"><ul class="megamenu level1"><li  class="mega first group"><div class="group"><div class="group-title"><a href="#"  class="mega first group" id="menu229" title="Most Read This Week"><span class="menu-title">Most Read This Week</span></a></div><div class="group-content">	<div class="ja-moduletable moduletable_mega  clearfix" id="Mod241">
						<div class="ja-box-ct clearfix">
		<div class="ja-bulletin-wrap">
	<ul class="ja-bulletin_mega clearfix">
				<li class="clearfix">
												<div class="box-left">
			
									<a href="/advertising/special-advertising-feature-2/95223-guamanian-publisher-releases-children-s-picture-bible-in-four-pacific-island-languages" class="mostread-image">
						<img src="/images/resized/images/photos/2017/05-May/12/bibles_30_30.jpg" alt="Guamanian publisher releases children’s picture Bible in four Pacific Island languages" title="Guamanian publisher releases children’s picture Bible in four Pacific Island languages" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/advertising/special-advertising-feature-2/95223-guamanian-publisher-releases-children-s-picture-bible-in-four-pacific-island-languages" class="mostread">Guamanian publisher releases children’s picture Bible in four Pacific Island languages</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/advertising/special-advertising-feature-2/95222-heartfelt-happenings-this-may-at-hyatt-regency-saipan" class="mostread-image">
						<img src="/images/resized/images/photos/misc/hyatt08XL_30_30.jpg" alt="Heartfelt happenings this May at Hyatt Regency Saipan" title="Heartfelt happenings this May at Hyatt Regency Saipan" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/advertising/special-advertising-feature-2/95222-heartfelt-happenings-this-may-at-hyatt-regency-saipan" class="mostread">Heartfelt happenings this May at Hyatt Regency Saipan</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/regional-news/95306-palau-official-charged-with-assaulting-staffer" class="mostread-image">
						<img src="/images/resized/images/photos/Mugshots/LeonRemengesau01_30_30.jpg" alt="Palau official charged with assaulting staffer" title="Palau official charged with assaulting staffer" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/regional-news/95306-palau-official-charged-with-assaulting-staffer" class="mostread">Palau official charged with assaulting staffer</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/advertising/special-advertising-feature-2/95227-new-book-of-short-stories-2017-05-12" class="mostread-image">
						<img src="/images/resized/images/photos/2017/05-May/12/DBD_30_30.jpg" alt="New book of short stories " title="New book of short stories " />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/advertising/special-advertising-feature-2/95227-new-book-of-short-stories-2017-05-12" class="mostread">New book of short stories </a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			<li class="clearfix">
												<div class="box-left">
			
									<a href="/cnmi/cnmi-news/local/95366-cnmi-labor-sanctions-manpower-agency-for-failing-to-comply-with-regulations" class="mostread-image">
						<img src="/images/resized/images/photos/misc/departmentOfLabor04_30_30.png" alt="CNMI Labor sanctions manpower agency for failing to comply with regulations" title="CNMI Labor sanctions manpower agency for failing to comply with regulations" />					</a>
								
				</div>
								<div style="padding-left:40px" class="box-right">
				<a href="/cnmi/cnmi-news/local/95366-cnmi-labor-sanctions-manpower-agency-for-failing-to-comply-with-regulations" class="mostread">CNMI Labor sanctions manpower agency for failing to comply with regulations</a>
				<br/>
				
					<span class="post-date">	
										
				
								</span>
                        	
				</div>
		</li>
			</ul>
</div><script type="text/javascript">
  var Ja_direction = '';
  var cookie_path = '/';
  var cur_template_name = 'ja_teline_iv';
  window.addEvent('load', function(){

		   if(typeof(tmpl_name) =='undefined')
		   {
			  cookie_path = "ja_teline_iv_direction";
		   }
		   else
		   {
			  cookie_path = tmpl_name+"_direction";
		   }
		   Ja_direction = Cookie.read(cookie_path);
		   if(!Ja_direction)
		   {
				cookie_path = cookie_path.replace("_direction","_profile");
			   Ja_direction = Cookie.read(cookie_path);
		   }
		   var style_l_value = 'auto';
		   if(Ja_direction == 'rtl')
			{
			  					setStyleLinkWithRTLDirection();
						//	var ul_wrapper = $('Mod241').getElement("ul.ja-bulletin");
			//	ul_wrapper.getElements("li img").each();
			}
	});
</script>
<script type="text/javascript" language="javascript">
 function setStyleLinkWithRTLDirection()
 {
    var links = document.getElementsByTagName ('link');
		var script = document.createElement('link');
	script.setAttribute('type', 'text/css');
	script.setAttribute('rel', 'stylesheet');
	script.setAttribute('href', 'http://www.mvariety.com/modules/mod_jabulletin/assets/mod_jabuletin_rtl.css');
	document.getElementsByTagName("head")[0].appendChild(script);
 }
</script>		</div>
    </div>
	</div></div></li></ul></div></div>
</div></div></li><li  class="mega"><a href="/regional-news"  class="mega" id="menu210" title="Regional News"><span class="menu-title">Regional News</span></a></li><li  class="mega"><a href="/community-bulletin-sp-595"  class="mega" id="menu123" title="Community Bulletins"><span class="menu-title">Community Bulletins</span></a></li><li  class="mega haschild"><a  class="mega haschild" id="menu158" title="Variety Features"><span class="menu-title">Variety Features</span></a><div class="childcontent cols1 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 200px;"><div class="megacol column1 first" style="width: 200px;"><ul class="megamenu level1"><li  class="mega first"><a href="/special-features/green-tips"  class="mega first" id="menu159" title="Green Tips"><span class="menu-title">Green Tips</span></a></li><li  class="mega"><a href="/special-features/health-matters"  class="mega" id="menu142" title="Health Matters"><span class="menu-title">Health Matters</span></a></li><li  class="mega"><a href="/special-features/my-marianas"  class="mega" id="menu241" title="My Marianas"><span class="menu-title">My Marianas</span></a></li><li  class="mega"><a href="/special-features/special-advertising-feature"  class="mega" id="menu202" title="Special Advertising Features"><span class="menu-title">Special Advertising Features</span></a></li><li  class="mega last"><a href="/special-features/special-events"  class="mega last" id="menu200" title="Special Events"><span class="menu-title">Special Events</span></a></li></ul></div></div>
</div></div></li><li  class="mega haschild"><a href="#"  class="mega haschild" id="menu195" title="Advertising"><span class="menu-title">Advertising</span></a><div class="childcontent cols1 ">
<div class="childcontent-inner-wrap">
<div class="childcontent-inner clearfix" style="width: 200px;"><div class="megacol column1 first" style="width: 200px;"><ul class="megamenu level1"><li  class="mega first"><a href="/advertising/ad-rates"  class="mega first" id="menu132" title="Ad Rates"><span class="menu-title">Ad Rates</span></a></li><li  class="mega"><a href="/advertising/classifieds"  class="mega" id="menu439" title="Classifieds"><span class="menu-title">Classifieds</span></a></li><li  class="mega"><a href="/advertising/rfp-ifb"  class="mega" id="menu446" title="RFP &amp; IFB"><span class="menu-title">RFP &amp; IFB</span></a></li><li  class="mega"><a href="/advertising/special-advertising-feature-2"  class="mega" id="menu451" title="Special Advertising Features"><span class="menu-title">Special Advertising Features</span></a></li><li  class="mega last"><a href="/advertising/subscription" target="_blank"  class="mega last" id="menu116" title="Subscription"><span class="menu-title">Subscription</span></a></li></ul></div></div>
</div></div></li><li  class="mega"><a href="/contacts-sp-124"  class="mega" id="menu228" title="Contact Us"><span class="menu-title">Contact Us</span></a></li><li  class="mega last"><a href="http://www.postguam.com/"  class="mega last" id="menu453" title="Guahan News"><span class="menu-title">Guahan News</span></a></li></ul>
</div>            <script type="text/javascript">
                var megamenu = new jaMegaMenuMoo ('ja-megamenu', {
                    'bgopacity': 0,
                    'delayHide': 300,
                    'slide'    : 1,
                    'fading'   : 0,
                    'direction': 'down',
                    'action'   : 'mouseover',
                    'tips'     : false,
                    'duration' : 300,
                    'hidestyle': 'fastwhenshow'
                });
            </script>
            <!-- jdoc:include type="menu" level="0" / -->


<ul class="no-display">
    <li><a href="#ja-content" title="Skip to content">Skip to content</a></li>
</ul>            </div>
                        </div>
                        <div id="ja-topbar"
            	class="wrap ">
                   <div class="main clearfix">
           <!--
	<p class="ja-day clearfix">
	  <span class="day">Wed</span><span class="month">05</span><span class="date">17</span><span class="year">2017</span>	</p>-->
	 
	<p class="ja-updatetime"><span>Last update</span><em>Fri, 19 May 2017 12am</em></p>
	
			<div class="ja-healineswrap">
		
<div class="ja-headelines-buttons">
	<a class="ja-headelines-pre" onclick="return false;" href="/"><span>PREVIOUS</span></a>
    <a class="ja-headelines-next" onclick="return false;" href="/"><span>NEXT</span></a> 
</div>
	
	<em>Headlines:</em>
	<div   id="jalh-modid198" class="ja-headlines ">
		<div style="white-space:nowrap; " id="jahl-wapper-items-jalh-modid198">
		<!-- HEADLINE CONTENT -->
								<div class="ja-headlines-item jahl-horizontal" style="visibility:visible">
					<a  title="THE Northern Mariana Islands Swimming Federation has announced its official selection of swimmers who will represent the CNMI in the 17th FINA World Aquatics Championships in Budapest, Hungary from July 14 to 30."  href="/cnmi/cnmi-news/sports/95341-nmisf-names-bets-in-fina-world-championships"><span>NMISF names bets in FINA World Championships</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(Press Release) — In its ongoing efforts to support activities that enhance the CNMI’s reputation as a prime tourist destination, Marpac Inc. announced that it has donated over $2,500 in in-kind contributions to the organizers of the 22nd Governor’s Tournament of Champions, which will be held ..."  href="/cnmi/cnmi-news/sports/95342-marpac-donates-2-500-to-tournament-of-champions"><span>Marpac donates $2,500 to Tournament of Champions</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="WITH 16 gold, 11 silver medal and seven bronze medals, William S. Reyes Elementary School led the medal tally in the elementary school division of the Public School System-McDonald’s All-Schools Championships at the Hopwood Middle School ground last weekend."  href="/cnmi/cnmi-news/sports/95343-wsr-leads-elementary-school-medal-count-in-all-schools-finals"><span>WSR leads elementary school  medal count in All-Schools finals</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THE 670 Sonics outperformed the Natibu Warriors in the second half for a double digit lead to secure 56-40 win during last Monday’s game of the 2nd Annual Francisco M. Diaz Memorial Youth Basketball League U18 division held at the Gilbert C. Ada Gym."  href="/cnmi/cnmi-news/sports/95344-malasarte-powers-sonics-past-warriors-56-40"><span>Malasarte powers Sonics past Warriors, 56-40</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="WELLINGTON, New Zealand (AP) — Tonga Prime Minister Akilisi Pohiva says his country has withdrawn from hosting the 2019 Pacific Games because of its likely impact on the national economy, although the games organizing committee and Pacific Games Council say they believe the event will go ahead in ..."  href="/regional-news/95345-tonga-withdraws-from-hosting-2019-pacific-games"><span>Tonga withdraws from hosting 2019 Pacific Games</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="BEIJING (Reuters) — China’s growth took a step back in April after a surprisingly strong start to the year, as factory output to investment to retail sales all tapered off as authorities clamped down on debt risks in an effort to stave off a potentially damaging hit to the economy."  href="/regional-news/95346-china-s-economy-loses-momentum-as-policymakers-clamp-down-on-debt-risks"><span>China’s economy loses momentum as policymakers clamp down on debt risks</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="TOKYO (Reuters) — Japanese Princess Mako, the eldest granddaughter of Emperor Akihito, will wed a former college classmate, Japanese media reported, heating up debate on the ever-shrinking royal family since she must become a commoner after marriage."  href="/regional-news/95348-japan-princess-to-wed-sparking-debate-on-shrinking-royal-family"><span>Japan princess to wed, sparking debate on shrinking royal family</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="SEOUL (Reuters) — South Korea said on Wednesday it wanted to reopen communications with North Korea as new President Moon Jae-in seeks a two-track policy involving sanctions and dialogue with its reclusive neighbor to rein in its nuclear and missile programs."  href="/regional-news/95349-south-korea-says-it-wants-to-reopen-communications-with-north-amid-missile-crisis"><span>South Korea says it wants to reopen communications with North amid missile crisis</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="MANILA (AP) — Philippine President Rodrigo Duterte said Tuesday that he and Chinese President Xi Jinping resolved to strengthen their countries’ friendship during their meeting in Beijing, with China pledging to speed up infrastructure projects it is funding in the Philippines."  href="/regional-news/95350-philippines-china-vow-closer-ties-management-of-disputes"><span>Philippines, China vow closer ties, management of disputes</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="WASHINGTON (AP) — Hawaii Sen. Mazie Hirono is undergoing treatment for kidney cancer and says she has a favorable prognosis from her doctor in Washington."  href="/regional-news/95353-hawaii-senator-discloses-kidney-cancer-says-prognosis-is-favorable"><span>Hawaii senator discloses kidney cancer; says prognosis is favorable</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="HAGÅTÑA (The Guam Daily Post) — The Guam Power Authority and the U.S. Navy have entered into a lease agreement that would dedicate 164 acres of military land for the construction of renewable energy facilities with a 40-megawatt generating capacity."  href="/cnmi/cnmi-news/local/95354-guam-navy-sign-agreement-for-solar-facility"><span>Guam, Navy sign agreement for solar facility</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(BECQ) — As part of the regularly scheduled sampling, the Bureau of Environmental and Coastal Quality this week analyzed water samples collected from Saipan’s recreational western beaches and storm drainages, and 10 water samples collected from Tinian’s recreational beaches and storm water dra..."  href="/cnmi/cnmi-news/local/95355-green-flag-on-saipan-tinian"><span>Green Flag on Saipan, Tinian</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(Press Release) — Koblerville Elementary School announces the PTSA Family Fun Night and Mr. &amp; Ms. Umang coronation night on Friday, May 19, 2017, from 5 to 9 p.m."  href="/cnmi/cnmi-news/local/95356-koes-events-2017-05-18"><span>KoES events</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="ROTARY Club of Saipan secretary Greg Borja said they still have 600 dictionaries for distribution to third graders in the next school year."  href="/cnmi/cnmi-news/local/95357-rotary-club-to-continue-dictionary-distribution-program-next-school-year"><span>Rotary Club to continue dictionary-distribution program next school year</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THE Saipan and Northern Islands Municipal Council on Tuesday established a committee on municipal appointments."  href="/cnmi/cnmi-news/local/95358-saipan-and-northern-islands-municipal-council-creates-appointments-panel"><span>Saipan and Northern Islands Municipal council creates appointments panel</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THE Marianas Visitors Authority is taking a second look at the Flower Islands Project which was proposed four years ago by an industry stakeholder."  href="/cnmi/cnmi-news/local/95359-mva-revisits-flower-island-project-proposal"><span>MVA revisits Flower Island Project proposal</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="MORE than 100 individuals were “arrested” by Department of Public Safety bounty hunters during the annual jailhouse fundraiser at the GIG Discotheque on Tuesday."  href="/cnmi/cnmi-news/local/95360-dps-holds-jailhouse-fundraiser"><span>DPS holds jailhouse fundraiser</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="SUPERIOR Court Associate Judge Joseph N. Camacho granted an ex-parte motion for a DNA expert and an expert in Carolinian culture in a sexual-abuse-of-a-minor case."  href="/cnmi/cnmi-news/local/95361-court-to-appoint-dna-carolinian-culture-experts-in-sexual-abuse-of-minor-case"><span>Court to appoint DNA, Carolinian culture experts in sexual-abuse-of-minor case</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="FORMER Department of Public Safety Deputy Commissioner Ambrosio Ogumoro said the “feud” in Dec. 2010 between then-Gov. Benigno R. Fitial and then-Lt. Gov. Eloy S. Inos was about Ogumoro’s allegations against Inos’s daughter, Kaye, who was then the DPS boating law administrator."  href="/cnmi/cnmi-news/local/95362-ambrosio-ogumoro-fitial-protected-inos"><span>Ambrosio Ogumoro: Fitial protected Inos</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(MVA) — Think you have the best barbecue ribs on Saipan? Bring your recipe and see if the judges agree at the BBQ Pork Ribs Cook Off on Saturday, May 20. at the 19th Annual Taste of the Marianas International Food Festival &amp; Beer Garden."  href="/community-bulletin-sp-595/95363-bbq-pork-ribs-cook-off-at-taste-on-may-20"><span>BBQ Pork Ribs Cook Off at ‘Taste’ on May 20</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="HAGÅTÑA (The Guam Daily Post) — A 29-year-old man found in possession of drugs, bulletproof vests and Drug Enforcement Administration reports pled guilty to the charges before Judge Joaquin Manibusan Jr. of the District Court of Guam."  href="/cnmi/cnmi-news/local/95364-meth-distributor-on-guam-pleads-guilty-to-charges"><span>Meth distributor on Guam pleads guilty to charges</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="BIYU Hu, 35, also known as “Brother,” was arrested after a “buy-walk” operation executed by the CNMI Drug Enforcement Task Force that yielded over 43 grams of ice or methamphetamine."  href="/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000"><span>Biyu Hu arrested for ice trafficking; bail set at $500,000</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THE local Department of Labor has sanctioned YWA Human Resource CNMI Corporation for failing to comply with DOL regulations."  href="/cnmi/cnmi-news/local/95366-cnmi-labor-sanctions-manpower-agency-for-failing-to-comply-with-regulations"><span>CNMI Labor sanctions manpower agency for failing to comply with regulations</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="NORTHERN Marianas College President Dr. Carmen Fernandez said NMC will implement new projects that will help preserve and perpetuate local culture."  href="/cnmi/cnmi-news/local/95367-nmc-aims-for-preservation-of-local-culture-says-president"><span>NMC aims for preservation of local culture, says president</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="WASHINGTON, D.C. (Office of the CNMI Congressional Delegate) — U.S. Congressman Gregorio Kilili Camacho Sablan has joined 16 other members of the U.S. House of Representatives to introduce legislation that would bring back the authority of the Occupational Safety and Health Administration to requi..."  href="/cnmi/cnmi-news/local/95368-kilili-bill-will-strengthen-osha-protect-workers"><span>Kilili: Bill will strengthen OSHA, protect workers</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="SPEAKER Ralph Demapan says he supports legislation requiring guest workers to get a CNMI ID as part of a data system for the local Department of Labor."  href="/cnmi/cnmi-news/local/95369-speaker-supports-id-measure-for-guest-workers"><span>Speaker supports ID measure for guest workers</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="THE Commonwealth Healthcare Corporation will be getting two more doctors for its Family Care Clinic in the next six months, medical director Dr. Elizabeth Kohnen said."  href="/cnmi/cnmi-news/local/95371-chcc-to-hire-2-more-doctors-for-family-clinic"><span>CHCC to hire 2 more doctors for family clinic</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="INITIATIVE, Intelligence, Innovations, Investments or 4i-CNMI LLC has filed a lawsuit in Superior Court against the Commonwealth Utilities Corp. for breach of contract and unjust enrichment."  href="/cnmi/cnmi-news/local/95372-cuc-sued-for-breach-of-contract"><span>CUC sued for breach of contract</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="IMPERIAL Pacific International is a step closer to opening the casino portion of its hotel project in Garapan now that the Department of Public Works has approved its conditional certificate of occupancy."  href="/cnmi/cnmi-news/local/95373-imperial-pacific-gets-dpw-approval-to-open-casino"><span>Imperial Pacific gets DPW approval to open casino</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="(NMC) — Families and friends who are not able to attend Northern Marianas College’s 37th commencement exercise in person on May 20, 2017 at the Koblerville gymnasium can watch the event live online."  href="/community-bulletin-sp-595/95374-nmc-37th-commencement-exercise-will-stream-live-online"><span>NMC 37th commencement exercise will stream live online</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="TWENTY NMI swimmers — 12 from Tsunami Saipan Swimming Center and eight from Saipan Swim Club — will compete in the 2017 Guam Championships from May19 to 20."  href="/cnmi/cnmi-news/sports/95297-20-nmi-swimmers-off-to-guam-for-championships"><span>20 NMI swimmers off to Guam for championships</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="AS she adjusted her crown and greeted participants for the first 2017 5K Rum for Mom Saturday morning, Miss Marianas Peachy Quitugua could not be happier to see the great turn out for her community project honoring mothers and celebrating healthy living."  href="/cnmi/cnmi-news/sports/95298-nmi-runners-post-new-pbts-in-run-for-mom"><span>NMI runners post new PBTs in Run for Mom</span>
					</a> 
				</div>
						<div class="ja-headlines-item jahl-horizontal" style="visibility:hidden">
					<a  title="NAKED Fish Ridin’ Darrty remained the top contenders in the A Division of the 48th SEDA Bud Light Dart League as they hold a sturdy 42 win record after their victory against the 6JMS Predators 10-7 last Monday at Naked Fish to fortify their spot at second place."  href="/cnmi/cnmi-news/sports/95299-ridin-darrty-nips-win-over-predators-to-keep-2nd-seat"><span>Ridin’ Darrty nips win over Predators to keep 2nd seat</span>
					</a> 
				</div>
						<!-- //HEADLINE CONTENT -->
		</div>	
	</div>
	
</div>
<script type="text/javascript">
// options setting
var options = { box:$('jalh-modid198'),
				items: $$('#jalh-modid198 .ja-headlines-item'),
				mode: 'horizontal',
				wrapper:$('jahl-wapper-items-jalh-modid198'),
				buttons:{next: $$('.ja-headelines-next'), previous: $$('.ja-headelines-pre')},
				interval:3000,
				fxOptions : { duration: 500,
							  transition: Fx.Transitions.linear ,
							  wait: false }	};

var jahl = new JANewSticker( options );
</script>

		
	
	         <div id="ja-headtools" class="ja-headtool">
  <ul>             
        <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#">
<head>
</head>
<body>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
</body>
</html><span id="ty2udate287"><div style="margin:0px auto;width:auto;text-align:right;">Thursday, May 18, 2017-1:45:18P.M.</div></span><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#">
<head>
</head>
<body>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
</body>
</html>
    </ul>
</div>            </div>
                        </div>
            
    <!-- MAIN CONTAINER -->
    <div id="ja-container" class="wrap ja-r1">
               <div class="main">
                           <div class="main-inner1 clearfix">
                        <div id="ja-mainbody" style="width:83%">
            <!-- CONTENT -->
            <div id="ja-main" style="width:100%">
            <div class="inner clearfix">

                
<div id="system-message-container">
</div>
                
                <div id="ja-contentwrap" class="clearfix ">
                    <div id="ja-content" class="column" style="width:100%">
                        <div id="ja-current-content" class="column" style="width:100%">
                            
                                                        <div id="ja-content-main" class="ja-content-main clearfix">
                                <div class="item-page">
	<h2 class="contentheading">
			<a href="/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000">
		Biyu Hu arrested for ice trafficking; bail set at $500,000</a>
		</h2>

	
<div class="article-tools clearfix">
	<ul class="actions">
						<li class="print-icon">
			<a href="/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000?tmpl=component&amp;print=1&amp;layout=default&amp;page=" title="Print" onclick="window.open(this.href,'win2','status=no,toolbar=no,scrollbars=yes,titlebar=no,menubar=no,resizable=yes,width=640,height=480,directories=no,location=no'); return false;" rel="nofollow"><img src="/media/system/images/printButton.png" alt="Print"  /></a>			</li>
		
					<li class="email-icon">
			<a href="/component/mailto/?tmpl=component&amp;template=ja_teline_iv&amp;link=ad8a3e270c4e9801efd4e95fc5ab6a122731d5f1" title="Email" onclick="window.open(this.href,'win2','width=400,height=350,menubar=yes,resizable=yes'); return false;"><img src="/media/system/images/emailButton.png" alt="Email"  /></a>			</li>
				
				
		
	</ul>



	<dl class="article-info">
	<dt class="article-info-term"></dt>
	<dd class="create ja-blog-date">
			<div class="inner clearfix">
								<span class="date">18</span>
				<span class="month-year">
					<strong>May</strong>
					<strong>2017</strong>
				</span>
							</div>
	</dd>
	<dd class="createdby"> 
				By Bryan Manabat - bryan@mvariety.com - Variety News Staff		</dd>
	
	</dl>
</div>
	<div class="bt-social-share bt-social-share-above"><div class="bt-social-share-button bt-facebook-share-button"><img class="fb-share" src="http://www.mvariety.com//plugins/content/bt_socialshare/assets/share.png" onClick="window.open('http://www.facebook.com/sharer.php?u='+encodeURIComponent('http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000')+'&t='+encodeURIComponent('Biyu Hu arrested for ice trafficking; bail set at $500,000'),'sharer','toolbar=0,status=0,left='+((screen.width/2)-300)+',top='+((screen.height/2)-200)+',width=600,height=360');" href="javascript: void(0)" /></div><div class="bt-social-share-button bt-facebook-like-button"><fb:like send="false" colorscheme="light" font="arial" href="http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000" layout="button_count" width="70" show_faces="true" action="like"></fb:like></div><div class="bt-social-share-button bt-twitter-button" style="width:80px"><a href="http://twitter.com/share" class="twitter-share-button" 
						  data-via="Marianas Variety" 
						  data-url="http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000" 
						  data-size="medium"
						  data-lang="en"
						  data-count="horizontal" >Twitter</a></div><div class="bt-social-share-button bt-googleplus-button"><g:plus action="share" href="http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000" annotation="bubble" height="20" ></g:plus></div></div>

<!-- JoomlaWorks "DISQUS Comments for Joomla!" (v3.2) starts here -->

<span id="startOfPage"></span>


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#">
<head>
</head>
<body>
<p style="text-align: justify;">BIYU Hu, 35, also known as “Brother,” was arrested after a “buy-walk” operation executed by the CNMI Drug Enforcement Task Force that yielded over 43 grams of ice or methamphetamine.</p>
 
<p style="text-align: justify;">Hu was arrested at her residence directly behind the San Antonio Church on Tataga Street.</p>
<p style="text-align: justify;">Hu, who was previously employed as a masseuse at Hanamitsu, appeared on Wednesday before Superior Court Associate Judge Teresa Kim-Tenorio on charges of possession and trafficking a controlled substance, to wit: methamphetamine or ice.</p>
<p style="text-align: justify;">The judge imposed a $500,000 cash bail on the defendant whose lawyer is Assistant Public Defender Tillman Clark. Also appearing for the defendant was an interpreter, Jean Shi, while the government was represented by Assistant Attorney General Chester Hinds.</p>
<p style="text-align: justify;">According to the CNMI Drug Enforcement Task Force, it learned from surveillance and a cooperating defendant, that Hu was dealing ice in and out of her residence in San Antonio.</p>
<p style="text-align: justify;">The task force conducted a monitored buy-walk operation on three separate occasions involving Hu that yielded a total of 43.1 grams worth $7,000.</p>
<p style="text-align: justify;">The task force said its informant bought 10.6 grams of ice worth $2,000 in the first operation; 5.3 grams of ice worth $1,000 in the second operation; and 27.2 grams of ice worth $4,000 in the third operation.</p>
<p style="text-align: justify;">The task force also executed a search warrant for Hu’s residence and seized items, evidence and instrumentalities of controlled substance distribution.<img src="/images/photos/misc/meth09XL.jpg" alt="" style="float: right;" width="1" height="1" /></p>
</body>
</html>
<!-- DISQUS comments block -->
<div class="jwDisqusForm">
<hr />
<img src="/plugins/content/jw_disqus/jw_disqus/tmpl/images/addacomment.png">
	
			<div id="disqus_thread"></div>
			<script type="text/javascript">
				//<![CDATA[
				var disqus_shortname = 'mvariety';
				var disqus_url = 'http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000';
				var disqus_identifier = 'd8d2d98882_id95365';
				var disqus_developer = '0';
				var disqus_config = function(){
					this.language = '';
				};
				(function() {
					var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
					dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
					(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
				})();
				//]]>
			</script>
			<noscript>
				<a href="http://mvariety.disqus.com/?url=ref">View the discussion thread.</a>
			</noscript>
				<div id="jwDisqusFormFooter">
		<a target="_blank" href="http://disqus.com" class="dsq-brlink">
			blog comments powered by <span class="logo-disqus">DISQUS</span>
		</a>
		<a id="jwDisqusBackToTop" href="http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000#Top">
			back to top		</a>
		<div class="clr"></div>
	</div>
</div>

<div class="clr"></div>


<!-- JoomlaWorks "DISQUS Comments for Joomla!" (v3.2) ends here -->
<div class="fb-recommendations-bar" data-href="http://www.mvariety.com/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000" data-read-time="30" data-action="like" data-trigger="onvisible" data-side="right" data-num_recommendations="2"></div><div id="fb-root"></div>
				<script>(function(d, s, id) {
				  var js, fjs = d.getElementsByTagName(s)[0];
				  if (d.getElementById(id)) {return;}
				  js = d.createElement(s); js.id = id;
				  js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1";
				  fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));</script><script src="//platform.twitter.com/widgets.js" type="text/javascript"></script><script type="text/javascript" src="https://apis.google.com/js/plusone.js">{lang: 'en-GB'}</script>	
	</div>                            </div>
                            
                                                    </div>

                                            </div>

                    
                </div>

                            </div>
            </div>
            <!-- //CONTENT -->
            
        </div>
                <!-- RIGHT COLUMN-->
        <div id="ja-right" class="column sidebar" style="width:17%">

            
                        <div class="ja-colswrap clearfix ja-r1">
                                <div id="ja-right1" class="ja-col  column" style="width:100%">
                    	<div class="ja-moduletable moduletable  clearfix" id="Mod253">
						<h3><span>More News</span></h3>
				<div class="ja-box-ct clearfix">
		<ul class="latestnews">
	<li>
		<a href="/cnmi/cnmi-news/local/95354-guam-navy-sign-agreement-for-solar-facility">
			Guam, Navy sign agreement for solar facility</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95355-green-flag-on-saipan-tinian">
			Green Flag on Saipan, Tinian</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95356-koes-events-2017-05-18">
			KoES events</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95357-rotary-club-to-continue-dictionary-distribution-program-next-school-year">
			Rotary Club to continue dictionary-distribution program next school year</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95358-saipan-and-northern-islands-municipal-council-creates-appointments-panel">
			Saipan and Northern Islands Municipal council creates appointments panel</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95359-mva-revisits-flower-island-project-proposal">
			MVA revisits Flower Island Project proposal</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95360-dps-holds-jailhouse-fundraiser">
			DPS holds jailhouse fundraiser</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95361-court-to-appoint-dna-carolinian-culture-experts-in-sexual-abuse-of-minor-case">
			Court to appoint DNA, Carolinian culture experts in sexual-abuse-of-minor case</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95362-ambrosio-ogumoro-fitial-protected-inos">
			Ambrosio Ogumoro: Fitial protected Inos</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95364-meth-distributor-on-guam-pleads-guilty-to-charges">
			Meth distributor on Guam pleads guilty to charges</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95365-biyu-hu-arrested-for-ice-trafficking-bail-set-at-500-000">
			Biyu Hu arrested for ice trafficking; bail set at $500,000</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95366-cnmi-labor-sanctions-manpower-agency-for-failing-to-comply-with-regulations">
			CNMI Labor sanctions manpower agency for failing to comply with regulations</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95367-nmc-aims-for-preservation-of-local-culture-says-president">
			NMC aims for preservation of local culture, says president</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95368-kilili-bill-will-strengthen-osha-protect-workers">
			Kilili: Bill will strengthen OSHA, protect workers</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95369-speaker-supports-id-measure-for-guest-workers">
			Speaker supports ID measure for guest workers</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95371-chcc-to-hire-2-more-doctors-for-family-clinic">
			CHCC to hire 2 more doctors for family clinic</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95372-cuc-sued-for-breach-of-contract">
			CUC sued for breach of contract</a>
	</li>
	<li>
		<a href="/cnmi/cnmi-news/local/95373-imperial-pacific-gets-dpw-approval-to-open-casino">
			Imperial Pacific gets DPW approval to open casino</a>
	</li>
</ul>
		</div>
    </div>
	                </div>
                
                            </div>
                                </div>
        <!-- //RIGHT COLUMN-->
                            </div>
                            </div>
                </div>
        <!-- //MAIN CONTAINER -->

                <div id="ja-footer"
            	class="wrap ">
                   <div class="main">
                           <div class="main-inner1 clearfix">
                <div class="ja-footnav">
		
<ul class="menu-nav">
<li class="item-231"><a href="http://www.mvariety.com" >Home</a></li><li class="item-232"><a href="/cnmi-sp-769" >CNMI</a></li><li class="item-236"><a href="#" >Regional News</a></li><li class="item-230"><a href="/community-bulletin-sp-950" >Community Bulletin</a></li><li class="item-233"><a href="/special-features-sp-395" >Variety Features</a></li><li class="item-235"><a href="#" >Advertising</a></li><li class="item-204"><a href="/contact-us" >Contact Us</a></li><li class="item-203"><a href="/user-content-posting-rules" >User Content Posting Rules</a></li></ul>

				<ul class="ja-links">
						<li class="top"><a href="#Top" title="Back to Top">Top</a></li>
		</ul>
		
		<ul class="no-display">
			<li><a href="#ja-content" title="Skip to content">Skip to content</a></li>
		</ul>
	</div>
		
	<div class="ja-copyright">
		

<div class="custom"  >
	<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://ogp.me/ns#">
<head>
</head>
<body>
<p><small>Copyright © 2013 Marianas Variety. All Rights Reserved. Published by Younis Art Studio Inc.</small></p>
</body>
</html></div>

	</div>                </div>
                            </div>
                        </div>
            
</div>



</body>

</html>